anyone with an outer orbit fixture, how can i fix this?

champscorner

Premium Member
i just received my 48" 2x250w mh and 4 t5's outer orbit. i plugged everything in to make sure all was well. all was well except the side fan is extremly loud. has anyone had this problem or know how i can fix it???
 

champscorner

Premium Member
i will definatley be looking foward to see how yours sounds. the top fan is quite it's the side fan that's crazy loud.
 

GobyJohnKenobi

New member
The side fan on my Orbit PC was loud for the first few days and then it mysteriously quieted itself down. All I hear is the air rushing thru the fixture now.

Hopefully yours just needs a little run-in time, too.

If it doesn't quiet down in about a week, contact them for a replacement fan.
 

davocean

New member
My first one was loud when I brought it home, called current and they gave me another one, no problem, very quiet.
Sometimes they get bounced in shipping.
 

boilermaker1

New member
tap (or whack) the side of the housing the fan wobbles a little and hits the housing... hence the noise. If you can knock the shaft straight, it'll quiet down.
 

davocean

New member
Are you suggesting doing the "Fonzie" to fix the loud fan?
Don't do that dude, they're really cool w/ customer service, just call or e-mail.
All the fans should sound the same.
 

DarthBaiter

New member
Champ, it really depends on the sound. I got mine yesterday and it is making a loud whining noise. I decided to give it a few day to break in, and see what happens from there.
 

champscorner

Premium Member
thanks all. ya i think i'll pass on the "fonzie" with the fixture being so expensive and all. Darth, that's exactly what mine sounds like i want to try to break it in as well but my tanks new and i'm not finished with the plumbing yet. does anyone have an opinion on just setting it up anyway and running it over a dry tank for maybe 10hrs a day to see if i can get it broke in?
 

champscorner

Premium Member
<a href=showthread.php?s=&postid=9234775#post9234775 target=_blank>Originally posted</a> by texasarrowhead
I should have mine by friday.So what you think about the color?


I set it up over a bare tank but it seems to be very bright. the t5's look really nice by themselves. the lunar lights are very bright(maybe too bright), i'm not liking the color of the 10k german bulbs that come with it, they seem very yellow and drowned out the t5 s. once i get some actual water and lr in there and get another look i may switch to a little more blue of a bulb, maybe pheonix 14k(heard good things). the fixture itself seems pretty well built except for the loud side fan, very sleek looking. good luck to all that have one on order. i'd like to hear back to see how everything was with all of yours. thanks again.
 

davocean

New member
I would at least let current know of this so they can address it and maybe deal w/ this as a shipping error.
It's good to at least document that you received it like this.
I'm happy w/ mine, but I have come to decide 10K is a little yellow.
I'm getting 14K very soon.
 

GuOD

New member
My fan also arrived noisy but a bulb broke during shipping which could have caused this. Current has been very good about helping with the situation. I definitely recommend contacting them.

(I took davocean's advice!)


Also - I find mine to be a bit yellow also. I was considering switching bulbs but I think Phoenix 14k + Actinics will result in a tank that looks like it has actinics on only.

I'd really like the tank to look "white" with the MH+T5 on all at once.
 

benray4fun

New member
I have the 150w version and that drowns out the pc's, so I'm not surprised at all to hear your 250w drowned anything out. Mine seem too bright as it is, it bleached out my live rocks and killed/burned a coral. Watch out...he, he... also, one of my fans didn't work at all, i don't know which I would prefer...out or noisy. I have fans installed in my wood canopy so it didn't matter to me...:D
 

champscorner

Premium Member
davocean, thanks for the advice!!! just got off the line with current and they are sending me out a new fan today. had no problems with them at all, good customer service. i think i will still run the exsisting fan for a few more days just to see if it may break in. still would like to hear about everyone elses fixtures though.
 

champscorner

Premium Member
anyone get their fixtures in yet. if so any problems? i've ran mine for a few days now and the fan is still very loud and annoying. glad i have another one on the way but hope it's not as loud as this one.
 
Top