Apex...email setup, freezing screen, remote access

saltwater101

New member
I tried to read through all the threads on RC forum regarding Apex setup but it just seems to be more than I can digest... therefore I need to ask for your help before I do this... :headwally:

I have the EB8, Apex controller and display, connected via ethernet cable to router Netgear WNR1000. My modem is Motorola Surfboard SB6120 and I use comcast cable internet.

Problem #1 - I can't get email setup. 60% of the time time when I modify the email setup information via computer and hit "update network settings", the controller freezes (Apex website keeps loading until it times out, and the display does not respond at all when I touch any button). For the 40% time that I am able to change the info, no test message is sent out.

Here is one of the attempts and the output when I telnet into Apex to see if email is sent.
034479f8.gif


Attempt #2 (changed port to 25)
93845f4c.gif

487c74bc.gif


Problem #2 - I am able to access Apex online when I am home, but not away from home. Here's my current setting... I don't think I chose a static IP for Apex... also, I have a IP camera that I can view away from home, and that is using port 80. I know the IP camera is done via port forwarding but I just can't remember how I did it before....

4e48168a.gif

ece94bbd.gif

cd5db80d.gif

542f83e3.gif


Please let me know if I need to provide any additional information for trouble shooting. Any help will be greatly appreciated. Sorry for the super long post and thank you in advance for your time.
 

RussM

New member
You do not have email authentication enabled - the email diagnostic outputs show that as the error encountered. Enable auth in the Apex, Update settings, and try again.

Your port forwarding looks OK - it should be working. But, you do need to reconfigure the Apex for a static IP address. In the router, on the LAN setup page, edit the DHCP Server End address, change it to .99. Then, change the Apex to a static address by disabling DHCP on the Network setup page. Change the 192.168.1.16 address to anything you want > 99 and < 254... 192.168.1.100 is a nice round easy to remember one! Then, make sure your 'netcam IP address is static as well (I suspect it is already). You can keep it at 192.168.1.178. The goal of changing the router's dynamic address pool is so that the router cannot inadvertently dynamically assign an IP address to some new device when that address is already statically assigned to another device (like the Apex or camera) Basically, we have allocated the .2-.99 address range exclusively for dynamic use, and everything above that for static use.

Next, remove and recreate the Apex port forwarding rule to use the new Apex IP address.

If you can't get external access working, try using a different http port in the Apex and in the port forwarding... go higher, such as 4567
 

saltwater101

New member
Thanks for the detailed instruction. really appreciate it!

I tried enabling the email auth and still did not seems to work. (apex froze in 2x in this process)
4246f434.gif


I changed the IP address as instructed. Will test it when I get to a different network soon. Will report back tonight if it worked. In the mean time, here's the screenshot in case I already screwed up step 1...
43b38bb4.gif
 

RussM

New member
ATT is such a PITA. Try outbound.att.net for the SMTP server. If no joy, just get a free GMX account to use for the Apex.

Revised network settings and port forwarding look good.
 

RussM

New member
192.168.x.x are private addresses.... they cannot be used over the Internet. You need to use your router's public address. You can find it by looking in the router (usually on the main status page), or by visiting some websites like:

http://www.reeftronics.net/showip.php
http://ipchicken.com
http://www.whatismyip.com/

When you find it, and put it in a URL like http://24.165.98.122:1027 (replacing the example IP address I've used), your router's port forwarding will then forward the traffic received on port 1027 to the Apex's actual IP address.
 

saltwater101

New member
I got mail =)

I got mail =)

I tried using various emails from different service providers and none of them worked. Finally opened a GMX account and got my 1st Apex email.:spin1:

I also found my external IP address and I am able to access Apex website away from home!

I am so excited:dance:

Do you have any idea why my apex screen & website keeps freezing/lost connection when i make changes? Also, when I telnet into Apex, I ran into the following: (1) it would say not able to connect via port 23, wait a while and try again and it may or may not work (2) i typed in the beginning of my password and it won't respond anymore, I can't see any letter as I continue to type. eventually it will lost connection to host.
I must have unplugged the controller from EB8 like 5 times within 30-minutes to get it to respond again.... it was getting very frustrating to say the least.

Thank you Russ and Reef Central... you are definitely a life saver :thumbsup:
 
Top