Apex Remote Internet Access Problem

sirjohn

Feeding Frenzied
I'm sure that there is a simple answer to this. I am using the Apex iPhone app and have inputted my correct IP address and port (80) into the app. I have also enabled port forwarding on my router to point the incoming connection on port 80 to the right LAN IP address.

It works great when I'm at home on the same LAN, bu the minute I leave and I'm on another network (whether AT&T's LTE or whatever), I get a "Request Time Out Error" (through the APEX app) or a 502 Bad Gateway Error (through the internet).

At first I suspected a firewall, but even disabling the firewall on my router does nothing. Anyone know what the problem is?
 

morty

Premium Member
Have you looked at chapter 2 of the Comprehensive Apex Manual PDF, starting at page 28? You can download it from Neptune's site. It might be that you are using the "local" IP address (192.168..etc.) rather than the WAN IP address issued to you by your ISP.
 

RussM

New member
There's no "might" about it - when away from home, you MUST use the public IP address of the router and the external/public port used in the port forwarding.

In the app, configure a new controller profile using the public IP address and port.

Depending on your router, that new profile might also work while at home on WiFi - if it does, you can delete the original profile in the App. If it doesn't work while at home, you'll need to keep both controller profiles. One will work when at home, the other will work when not at home.
 

morty

Premium Member
My using the word "might" was only suggesting that the OP may have been been making the mistake of using non-WAN settings in his/her configuration. Who knew, at that point? It wasn't to suggest that "sometimes the external port settings work, sometimes they don't."
 

sirjohn

Feeding Frenzied
Thanks everyone for your responses.

I am using a Linksys EA3000 router. The modem is an Aris modem/wi-fi combo (Xfinity internet) that is placed on bridge mode. I am definitely not using the local IP address, but rather the "public" IP address for the router, as listed on the "Status" page. I'm also using the external port for the router and the APEX, which is 80 (default).

I will try configuring a new controller profile as Russ suggested and let you know what happens
 

sirjohn

Feeding Frenzied
Problem fixed! It was an unusual issue. In the Network Setup Configuration web page, the "AquaController IP address" had a different IP address than the base unit was actually using, and I have no idea why. DHCP was on for both the base unit and the web page, so the IP addresses should have never been different. Thus, I suspect when I tried to use the public IP address on the Apex App (which must be web-based), it was re-routing to the incorrect local IP address as shown on the web page, rather than to the correct local IP address the base unit was actually using.

At first I tried manually changing the IP address in this box on the web page to match the one I know the base unit was using (by looking at the base unit itself), but the address wouldn't take. It wasn't until I also checked off the "Reboot System After Update" box that it finally took. And then everything worked.

It seems that the "Network Setup Configuration" web page/settings are not entirely in sync with the network settings on the base unit itself, and that sometimes you may have to manually set each one. Also, if you make changes on one, you will need to make sure to make changes on the other. Don't know if that's a bug or intentionally, but the guys at Neptune can probably answer that one.
 

morty

Premium Member
FWIW, I prefer to disable DHCP and set static local IP addresses on devices like an Apex or IP camera, intentionally outside of the auto-assign DHCP range of the router. For example, if my router is set to dynamically assign addresses in the 192.168.1.100-150 range, I turn off DHCP on my Apex and set it to use 192.168.1.155. (It also doesn't hurt to set it to use an internal port other than 80.) Then, in the router's port forwarding setup, for additional security, I also set it to use an external port other than 80, and set it to forward to 192.168.1.155 and whatever internal port I chose.

The reasoning is that, in the event of a power failure, when the router and connected devices boot up again, you can be sure that the local IP address assigned to the Apex will not change (as it could under DHCP) and potentially goof up external port forwarding, which could be a problem if you are away from home when the rebooting occurs. This is also sort of covered on p. 28 of the Comprehensive Apex PDF.
 
Top