Fighting a beckett skimmer problem

Aquatic Hamster

New member
I have used an MRC MR-2 with two becketts for a year now and it has been great. The becketts are driven by a Tarpon pump and the installation is external to the sump. Starting Sunday after a water change I noticed it not generating much foam or bubbles. When trying to raise the water level so the foam would reach the cup the becketts stop generating bubbles at all. Lowering the water level back down to MRC's recommendation it generates a lot of bubbles, but it still doesn't seem right. I have cleaned both becketts, the skimmer body, the waste line to the waste container, the shutoff valve in the wast container and even the gate valve.

After 1 full day it has started getting some dry foam up to the collection cup, but I usually like to run it a lot wetter. Just not sure what else to look for. ??????????
 

HotHotHot

Obligate Coral Killer
You didn't mention cleaning the air intakes. I get a lot of salt creep around mine. Enough to block the flow of air.

Flush some tank water, although warm RODI would be best, though the intake to see if it flows into the beckett chamber.

HTH
Ed
 

Aquatic Hamster

New member
Sorry you are right, I didn't mention them. But I did clean both intakes even using some vinigar as there was some salt creep into it. They are clean and currently running with out the muffler piece and cotton on the end.
 

Aquatic Hamster

New member
Yes I did disconnect it, but there is not a blockage.

I just heard from Tim at MRC. Amazingly someone who is typing this message forgot to check for blockages in the pump. I was so concentrating on the skimmer parts the Tarpon was completely out of thought. Will be checking it soon.
 
Top