Frowgspawn Question

rverbeck

New member
Why would my skeleton on my frogspawn be deteriating? My calcium levels are @ 440. The rest of my params:
Nitrates0
Nitrites0
ammonia0
alk3.5
ph8.4

The fleshy parts look fine. It only the skeleton. Doesnt look like anything is eating it either. looks more like it has thinned out.
 

cfw1199

New member
pic please..........what part are you talking about....is the deteriation anywhere nere the heads......
 

acrouse

New member
rverbeck-I know exactly what you are talking about-mine is doing the same thing. The heads are growing excellent -but the skeleton part is thining out. I have had to move it a couple times because of the growth of the heads, but I am very careful because it feels like the base could just crumble in my hands-very thinning like you described. I have not had any trouble with my calcium levels either.
I hope someone has an answer as I would be interested to know also. A picture of mine would not help, because looking at it, it looks fine-its only once you touch it that you can tell its thinning.
I actually have mine stuck in a hole in a rock-didn't glue it -just self anchored-and I am afraid someday I will go down to my tank and the base will be in the rock and the heads on the bottom from it breaking apart!!! Good Luck jolene
 

rverbeck

New member
Hate to hear that your having the same issue. I would get a picture but my camera is horrible and would not work. Hopefully by you bringing this thread back to life, we might hear somehting.
 

BigManBud

Premium Member
I have the same problem with mine. After it broke off of the base it was glued to, I was trying to stick it in a hole in a rock and it just split up the middle, completely in two. I now have two. The heads look fine and they are growing. Hopefully somebody will chime in that knows whats wrong.
 

weaselslucks

New member
what about your mag and how are you testing alk? if the test is in drops 3.5 is low it should be alteast 6. is the the calcium in your tank keylated(sp)? if you dont have anout mag or i f the alk is off the calcium can't absord the right way
 

BigManBud

Premium Member
Cal is 425
alk is 8
mg is 1325
sg is 1.026 calibrated
all testing done with elos test kits
I dose with Mr. Randy's 2 part
I change approx. 20% every 10-14 days

All the other corals are fine, mostly sps
 

acrouse

New member
It seems strange that more than one person is experiencing the same thing-and parameters check out okay! I also hope we get more input/suggestions.
I would post a picture, but it shows nothing except the heads looking nice,-the skeleton doesnt look damaged-its only when you touch it that you notice the thinning.

It might be worth me doing some more reading on calcium absorption, as my alkalinity, mag, and calcium are all being tested with salifert test kits and test okay.

My concern is how will I keep the heads if the skeleton crumbles?
 

BigManBud

Premium Member
I dont understand, mine split right up the middle and now I got 2 frogspawns and both look great. Hopefully it wont crumble anymore than it already has.
 
Top