Old 9410.040 pump worth Repairing?

reefdude135

New member
Hi Roger:

My 9410 skimmer has served my reef extremely well --- much longer than I would have imagined! Alas, I replaced the pump this summer with a new unit that i purchased from you. All is good there.


I was wondering if there is any repair that I can perform on this old pump though, just to have an emergency backup. If I plug it in, it wants to turn the propellor, but it just won't free up and spin.. any thoughts?
 

rvitko

RC Sponsor
RC Sponsor
Could you post a couple pictures? Impeller outside the pump and inside of the impeller well? I would suspect if the motor has no swelling or deformation it can be repaired. It may just be some parts are locked up and no parts are needed.
 

reefdude135

New member
thank you! pics attached...

bfda300d4733f1ed12d7dcfa628d79c7.jpg


Sent from my SM-F711U using Tapatalk
 

rvitko

RC Sponsor
RC Sponsor
If you put your finger in the well, do you feel any bumps or blemishes? Will that rear bearing seat in the motor and stay in place?
 

reefdude135

New member
1. seems clear of bumps and blemishes.

2. yes.

if i put in the impeller without the cover and then plug in the pump, i feel the impeller wanting to turn but seems frozen... if i pull on the center shaft of the impeller, it will spin...

The magnet on the impeller looks scratched up (which you probably noted in the pics).

Sent from my SM-F711U using Tapatalk
 

rvitko

RC Sponsor
RC Sponsor
Something doesn't seem right with the bushing. When it is out, no orange should remain at the bottom of the pump. I am guessing the bushing is torn. The scratches are not ideal, but they should not stop it from working. If the bushing pushes in and stays in, a new 9410.047 drive unit should solve it, but you need to get the piece of the bushing out from down in the bushing seat.
 

rvitko

RC Sponsor
RC Sponsor
Yes, in fact if you took the bushing from the impeller cover, installed that in the back and took the other one without the torn off piece in the front, and the pump runs, we can be sure all you need is the impeller set.
 

reefdude135

New member
i did the switch, and it runs for about 5 seconds (then the magnet kinds locks up. if that makes sense). And I had the cover off too.

Sent from my SM-F711U using Tapatalk
 

rvitko

RC Sponsor
RC Sponsor
The cover would need to be on to keep the magnet centered, I am pretty sure the drive unit will solve it.
 

reefdude135

New member
awesome! is there specific part numbers that I should order? and where is best to place that order?

Sent from my SM-F711U using Tapatalk
 
Top