out of ideas

Irish1983

New member
5 months ago a coral brought in an external parasites into my friends 150gal mixed reef. It looked like lymphosis but then moved to on to slowly cover more and more of his 8 year old Hippo tang. From the way it looked I figured "worms" or maybe weird copepod and dosed Prazi accordingly to see if it would effect it. Nada. Spread to the other fish (took 2 weeks to start on them which were a flamer angle, fox face, and yellow tang). I pulled them all into QT and dosed copper power. It did not stop it. I slowly raised cu to 3 and still no dent. Lost the flame. Pulled copper and tried paraguard. It worked in QT. Fish healed up and I kept them 3 months. Put them back in the display and three days later I see it on the Hippo again. Out of desperation I try ruby red kick ich plus (fights externals doesn't let them attach easy). I dosed it for two months. Everyone healed and was fine. This last Friday I stopped before the weekend and I find this (see image). They are white and look embedded in the fishes side with white ropey "streamers" that flow in the current. I'm thinking egg sacks? What do you think is my next move is I have 1 week before this gets out of hand. It's not velvet no fish I have ever known lives with velvet covering it for 1 month. It's not ich. I can see them sticking out of the fishes sides. They don't look like cysts.

KJzHkaK.jpg
 

Irish1983

New member
I forgot to mention that FW dips had nothing fall off and after I cleared the Cu I did a methalene dip and they seemed to respond better but it didn't get rid of it that I noticed.
 
Top