problem with 7095

Doughster4

Premium Member
My 6200's stopped working over the weekend

I took everything apart, checked all connections. The pumps/drivers run fine ALONE but as soon as I connect the cables and 7095 they shutt off. NO lights appear on the 7095.

Please let me know what I need to do to have this checked out
 

rvitko

RC Sponsor
RC Sponsor
I have never seen a 7095 not work at all unless the culprit was a bad cable or water damage to the controller. I would try using another cable and double check the controller for any signs of water damage as this would not be covered under warranty. You can open it by removing the screws on the back. Usually what you describe would result from a short at the sockets where the pumps connect.
 

Doughster4

Premium Member
I have taken it apart. I see no signs of any moisture inside nor has it been exposed to any. I have tried connecting in different sockets too since I only run 2 6200's
 

rvitko

RC Sponsor
RC Sponsor
The controller came with 4 cables, please try the other 2, sometimes the cables develop an internal break if they are stretched. I see this most often in a situation where the controller is mounted on a door and the driver is in the cabinet and they are stretched when the door is open. I am not saying it is impossible but in 4 years I have not seen this yet so I just don't want you to waste money on shipping if another fix is possible.
 

rvitko

RC Sponsor
RC Sponsor
OK, send it in.

Tunze USA
305 Victor St
Austin TX 78753

Just include a note with your return address and phone number and a receipt if available
 
Top