Tunze Osmolator alarm issue?

tanksfishtank

Premium Member
My tunze osmolator high level alarm starts going off immediately after plugging it in and it won't shut off. I have moved the float switch, placed the optic sensor and pump in and out of water the water, and after nothing worked I soaked it in vinegar to clean the float with and pump. This did not fix the problem. Any idea's? TIA! -Tom
 

bblumberg

New member
Anybody have any recommendations?

First are you quite sure that you have set it up correctly? Does the alarm stop if you turn the high sensor upside down from where you have it now? If you are sure these things have been done correctly, then pop over to the Tunze forum and ask Roger what the next step is. The unit may be defective.
 

tanksfishtank

Premium Member
I have it setup according to directions and have had it setup and worked correctly on my previous system before the move. Who is Roger??
 

bblumberg

New member
I have it setup according to directions and have had it setup and worked correctly on my previous system before the move. Who is Roger??

Roger Vitko is the Tunze USA representative. He is very good about helping with problems and getting broken equipment back up and running.
 

gi_eric22

New member
Mine reacts the same way alarm on then it runs for about 30 seconds then shuts off. My research on the internet said this was normal.
 

tanksfishtank

Premium Member
My alarm starts immediately after plugging in and does not turn off. Pump won't start because the high level alarm stays on. Frustrating!
 

oldbones

New member
And you're definitely waiting at least 30 seconds after turning it on? Every time I turn mine on, the alarm sounds and the pump runs for what feel like forever, then it stops and all is normal.

Can you snap a pic of how you have your sensors set up?
 

minus9

New member
After powering up, it initiates the priming stage. If there is air in the pump, it will try to cycle/prime until water starts to pump. If it doesn't draw water or there's air preventing it from priming, it will give you an alarm. Simply put the pump on its side until the air clears.
 

tanksfishtank

Premium Member
Thank you for the ideas! I tried uploading pics/video but it won't allow them. This is how I have it set up. I have the pump set in ATO bucket, sensor set at desired water level, and float switch about 1 inch above the sensor. Once I plug the unit in, the alarm immediately goes off. The pump does not attempt to start or prime itself. I have waited for up to 3 minutes with the alarm going off, just to be sure and the pump never tries to start. I have flipped the float switch upside down to make sure it is not somehow backwards (I don't know how because it worked before our move to IA). Can anyone tag Roger or know his username so I can message him? Thanks you all again for the help!
 

tanksfishtank

Premium Member
Update: Got in touch with Roger Vitko (Tunze rep), and he had me mail him the controller. Once he received it, he diagnosed it as a bad controller (11 years old). Because it was not repairable, he offered 25% off new. Great customer service. Thanks for everyones advice/help!

FYI. If he could have fixed it, it would have been a flat rate $25 and that included returned shipping in case anyone else has this issue.
 

lubdafishes

New member
my best advice is not to get your hopes up. this is the best thing that never works. They work for about a year if you are lucky. I have purchased four over the yeas purchased new parts new pumps. BUY ANOTHER PRODUCT FORGET HOW WELL IT WORKS WHEN IT WORKS YOU WILL NEVER GET THAT HIGH AGAIN. I even recommended several others to purchase this product but the had the same fate offered to clean their tanks free geesh.
 

Grayhead

New member
my best advice is not to get your hopes up. this is the best thing that never works. They work for about a year if you are lucky. I have purchased four over the yeas purchased new parts new pumps. BUY ANOTHER PRODUCT FORGET HOW WELL IT WORKS WHEN IT WORKS YOU WILL NEVER GET THAT HIGH AGAIN. I even recommended several others to purchase this product but the had the same fate offered to clean their tanks free geesh.

Are you drunk posting? That makes absolutely no sense.
OP, glad you resolved your issue. Tunze makes outstanding products. My alarm and pump comes on Everytime I restart. I have my ATO and skimmer shut down if the power to the return pump goes off. Helps during feed cycles. When it comes on, it should only be for a few seconds.
 
Top