Stream 3 stopped running

beertech

New member
I have a 2ish year old stream 3.
Was working fine until this week.
It has been connected to my apex with no issues for the last year.
This week I noticed it had stopped and the controller is flashing orange wgere it says external control.
I tried disassembling the pump and thoroughly cleaned it.
Inspected the ceramic bushing at the base of the impeller and it looks fine.
Any ideas?
 

rvitko

RC Sponsor
RC Sponsor
Do any diagnostic lights show on the pump itself? The pump has a series of red and white LED's that are concealed and only visible when something is wrong, they are near the intake at the top on the front. I would open the controller as well and inspect if there is any water damage, which may not be by any fault of yours, for example the cable could be damaged or defective and wick water back, in this case it tends to surround the plug for the motor.
 

beertech

New member
Nope, there are no diagnostic leds showing on the pump.
I have seen them before, during initial set up so I know what they look like.
I will open the controller tonight and check it out.
Thanks Roger!
 

beertech

New member
Nope, there are no diagnostic leds showing on the pump.
I have seen them before, during initial set up so I know what they look like.
I will open the controller tonight and check it out.
Thanks Roger!
 

beertech

New member
Hi Roger, I found the issue.
The wire is indeed split open, but at the pump end where it connects to the body.
I got a picture, but can't upload it here.
I'm in Canada, so I will contact my local distributor for warranty support.
Thanks for the help!
 

rvitko

RC Sponsor
RC Sponsor
They should replace it unless there is signs of chewing/gnawing damage as on a newer pump this would likely be a defective cable. Older cords can harden and get brittle but that generally takes many years and the Stream 3 has a 5 year warranty.
 
Top