6105 pump intermittently working

fmuakkassa

Premium Member
I have two 6105 pump on each side of my 180 g reef aquarium hooked to a Tunze 7095 controller. One of the pumps works some times and sometimes it does not. If I disconnect the power supply from the pumps and controller, it might work again for days or weeks and then stop responding to the controller (lights on controller on but pump not working). I don't know if this is the pump or the 12 volt adaptor or controller. I was going top buy a new pump but can't find a 6105 even on Tunze.usa web site. Are they out of production? Any suggestion for a replacement Turbelle Stream pump that works with my controller.

Thanks
 

rvitko

RC Sponsor
RC Sponsor
The 6105 is still produced, they have been in very short supply since May as have many of our products due to lockdowns and supply chain disruption. There should be some available, but it is definitely limited.

How old is this pump? The main culprits tend to be mechanical, the metal shaft being loose or fused to the drive unit by calcium.
 

fmuakkassa

Premium Member
Bought it in January 2015.
I see the 6105 on Tunze website but it comes with it's own controller. Can I buy it separately since I already have a 7095 controller.

So you think I should dissemble it and clean it?

Thanks
 

rvitko

RC Sponsor
RC Sponsor
Since mid 2015 all pumps now include the controller, but the controller does not prevent connection to any other controller you wish to use.

I would definitely disassemble and clean the pump, it is not that old, the metal shaft should be firmly fixed in the motor and the impeller should spin freely on the metal shaft.
 

fmuakkassa

Premium Member
Thanks for the explanation.
I'll try the cleaning first and if it does not work buy a new 6105 and hook its controller to my 7095 one
 

rvitko

RC Sponsor
RC Sponsor
You should only need a 6105.100 motor at most. This would be a considerable savings over a complete pump.
 
Top