BRS Dual Reactor question

Dmoody

Artillery Drill
I am currently using the Bulk Reef Supply dual reactor with the recommended amount of ROX carbon and GFO. The pump I am using is a MJ 1200. I noticed the other day that with the ball valve wide open I wasnt getting much flow through the GFO stage. I took the pump and reactor apart, changed all the media, cleaned it out and cleaned the pump out. Then it worked fine. After about two days once again the flow is restricted. Does this mean the pump is not powerful enough? Is there a trick to getting it to work just right?
 

MattinIdaho

New member
I replaced my old soft chambers with the new style hard ones and I run into the same problem. I went back to the old original ones and have had no problems. Im going to take a dremel to the slits in the newer ones and open them up a little bit more.
 

Saltwatercoral2

New member
I noticed the same problem with the old style dual reactor.. I sold it and went and bought 2 single reactors the new style and have had no problems at all.
 

Dmoody

Artillery Drill
The output had slowed as well but and I don't like I am losing much the reactor sits pretty much parallel to the pump so head pressure is minimal.
 

mikecc67548

New member
As long as I was getting good flow out of my pump and down the line....I would suspect that the carbon was plugging off. Unless the GFO was bricking up on you. Try less carbon, or a courser grind of it.
 

Dmoody

Artillery Drill
I'm starting to think it may be the GFO because I'm getting minimal flow into that canister and its the first "stage"
 
Top