Telnet Access

ScottB

New member
Ok. I am running 4.11 on my APEX. From the web interface, everything seems to be functioning. However, when I attempt to telnet to the unit each keypress gets double input.

Assuming that I was using the default username/password (which I am not), the exchange looks like this:

AquaController Login
login: % !"'#aaddmmiinn^M
password: 1*2*3*4*^M


I am making this attempt on my internal network, on a Mac running Lion, using the built-in terminal client.

Am I the only one who see this and do I need to tweak my terminal settings, or is this something with the APEX itself?
 

aquamanic

WHO DAT??
If I recall from 'the day' there's a param called 'echo' which you need to find in the terminal client and turn off.
 

ScottB

New member
If I recall from 'the day' there's a param called 'echo' which you need to find in the terminal client and turn off.

Yeah, that's about what I figured. I rarely use telnet anymore due to its insecure nature. (I wish this thing supported SSL and SSH.) I actually think what I am looking for is localecho, but can't seem to find it just yet.

Thanks for the help.
 

bazineta

Premium Member
Unfortunately there seems to be some mismatch in the telnet NVT negotiation between the Apex and OS X telnet, and there's to my knowledge no way to disable local echo in the OS X telnet client. Annoying, basically, but I haven't found any way around it.
 

ScottB

New member
Unfortunately there seems to be some mismatch in the telnet NVT negotiation between the Apex and OS X telnet, and there's to my knowledge no way to disable local echo in the OS X telnet client. Annoying, basically, but I haven't found any way around it.

Sigh!
 

swearint

New member
I don't know if this will be of any use, I don't own a Mac. However, there is an iPhone app called Mocha Telnet Lite that works fine.

Todd
 

RussM

New member
The telnet client in OSX unfortunately doesn't always properly detect the telnet server's capabilities. I've seen this with devices other than Apex too. There is an easy solution:


From the terminal type telnet xxx.xxx.xxx.xxx where the x's are your IP address.

Then, once connected, hit ^] (Crtl+])

You should now see:
telnet>

Type 'mode line' (without the quotes) and hit enter.

Hit enter again until you see 'login:'

Now login with your login/password... there should be no strange or double echoed characters.
 

RussM

New member
I haven't tried it myself, but a colleague of mine swears by ITerm2, a free telnet client for Mac. Might be worth a try...
 

ScottB

New member
The telnet client in OSX unfortunately doesn't always properly detect the telnet server's capabilities. I've seen this with devices other than Apex too. There is an easy solution:


From the terminal type telnet xxx.xxx.xxx.xxx where the x's are your IP address.

Then, once connected, hit ^] (Crtl+])

You should now see:
telnet>

Type 'mode line' (without the quotes) and hit enter.

Hit enter again until you see 'login:'

Now login with your login/password... there should be no strange or double echoed characters.

That works. It is kinda clunky, though. Maybe I will give iTerm2 a shot.

Thanks.
 
Top