ATI Sunpower troubleshooting

20LogR

New member
Can anyone point me to a video or help explain how to remove the sockets on an ATI Sunpower? I see they pop in, but don't see how to remove them without breaking them. I have a second hand Sunpower that has two bulbs out. Bulbs 1 & 3 are out. I tested the bulbs first, and then swapped the mid and bottom ballast out but the bottom two lights are still out. That tells me it's not the ballast. I'm assuming next in line is the sockets?

Thanks
 

jwilliams860

New member
I just removed two in my sunpower. They have tabs on the bottom of them and they lean forward towards the middle of the fixture to come out. They go back in reverse of that.
 

20LogR

New member
Take apart the box your wiring goes into and tighten the connections

I went to Radio Shack and replace that piece as well, the contact screws were pretty rusted and I was getting inconsistent voltage across the terminals. It came in a big 12 point piece and I just cut it down for what I needed. I also replace the fan connetions while I was at it. (also having problems with the fans, but I'm not sure if the fans aren't just bad)
 

20LogR

New member
I just removed two in my sunpower. They have tabs on the bottom of them and they lean forward towards the middle of the fixture to come out. They go back in reverse of that.


On the bulb side of the fixture? I'm not seeing anything. Did you have to replace both or just one? I'm trying to figure out how many I should order.
 
Top