how to get gfo tumbling?

Mrbeachbum2

New member
I've had the brs gfo unit forever and can't get the GFO to tumble nicely. Am I missing something simple? I have a Maxi Jet 1200 hooked up to it and have tried altering the flow. I currently have 2 pads in the column, one on top and bottom.

Thanks!
 

billdogg

Active member
I would think that with a mj1200, you would have to dial it back quite a ways - are you losing a bunch of flow to restrictions or head pressure?
 

edsreef

New member
Make sure the tubing that the pump is connected to is going to the inlet on the filter housing marked "in".
 

iamwrasseman

New member
as edsreef stated make sure the water in flowing in ,in the center tube which is where it should be going in not out .the water should be flowing from bottom to top .
 

Lynnmw1208

New member
I only used one of the filter sponges in mine and I get a nice tumble. Did you make sure the ball valve is open (parallel to the tubing)? I always start with it open and slowly start dialing it back to where I want it. How much GFO did you put in? I put in 2 cups in mine and it was too much, I kept getting a clump stuck up in the top.
 

Mrbeachbum2

New member
I only used one of the filter sponges in mine and I get a nice tumble. Did you make sure the ball valve is open (parallel to the tubing)? I always start with it open and slowly start dialing it back to where I want it. How much GFO did you put in? I put in 2 cups in mine and it was too much, I kept getting a clump stuck up in the top.

What sponge do you take out? The water is definitely going through, but not sure if it's going from the bottom to the top.
 
Top