power filters too loud on 20L, how can I make it quiet?

mmm55645

New member
I have gone through two power filters on my 20L tank. They start out being almost completely silent, but as months go by they become very loud with a continuous grinding sound.

I try to clean them, but it does not solve the problem. After one did this, I bought another one thinking that would solve the problem. Now that the new one is 6 months old, it is making the same bothersome grinding sound.

I have cleaned the impeller as best as I can and the inside of the power filter.

I am wondering if maybe it is picking up too much sand in the 20L or something.

Is there a way I can clean it better or buy another impeller, or what can I do to end the grinding noise? It is getting to the point where I am going to have to unplug the thing at night so I can sleep(and I even like to have a continuous noise going).

Please help. ;) thanks
 

smorrow5773

New member
Have you tried soaking the parts in vinegar or muriatic acid? You probably have calcium deposits or sand in/on/around the magnet.
 

mouserusker

New member
If you have to buy a new one, perhaps you could wrap the intake with some sort of foam or filter sock. Then, if it happened again, you could mostly rule out sand as a factor.
 

mmm55645

New member
I soaked the parts in vinegar for a long time, and sadly it has not reduced the noise.

I am wondering if perhaps the parts have been ground down somehow by sand and that is what is making them loud?
The impeller looks clean, but I don't know.

I guess I'll have to buy another one and put a sponge over the end so it won't suck up course sand.
 

mouserusker

New member
Maybe you should consider trying a different brand of Power Filter.
Spend a little extra $$ now and perhaps you won't have to replace it in another six months.
 
Top