Wow so dissapointed with tunze powerhead

homeboyreefer

New member
Ok so after about a year and a bit i have finally gotten my tank up and running with work and moving, i had bought most of my equip last year so thank god i didn't have to spend much except on a profilux controller about to come. Now its been 2 months running and the clips on my tunze 6045 have broken and this is the LOUDEST powerheads i have ever heard, it chatters so loud you can hear it 20 feet away, i've used many tunze products before from the streams to skimmer, and ato
(which is the best product ever) and have always been very pleased but this is the first time i've been let down. I know that the 6045 is very cheap to buy but still its a sad day when a koralia in my tank is leaps quieter. The clip is cheap enough for me to replace and i'm just going to gorrila glue it on, but has anybody else noticed the NOISE and what have you guys done to quiet it down?
 

rvitko

RC Sponsor
RC Sponsor
It sounds like an old 6045 with some defects, likely one of the first production run. Send it in and I will replace it, the new ones are great pumps and all of these issues have been solved.

Tunze USA
305 Victor St
Austin, TX 78753
 

five.five-six

Premium Member
I had a few early 6045's and roger fixed them up just fine. I have been running them for about 18 months now and would never run anything else
 

moonyguy

Premium Member
Tunze has the best customer service and products I have ever seen. Being a poor grad student I have learned to save up and buy good products like Tunze because if anything happens Roger is always there to take care of the problem and fix it...often free of cost. I have never seen any company do that so far except may be LA for livestock. I am sure Roger will take care of the issue. Good luck with your new tank.

Vishnu
 

poolkeeper1

New member
Absolutely excellent service, Also had a bad 6045 Roger replaced with the new model and has worked flawless since. You can't beat Tunze for service and quality products anywhere!!!
 

Zoanut

New member
<a href=showthread.php?s=&postid=14816595#post14816595 target=_blank>Originally posted</a> by rvitko
It sounds like an old 6045 with some defects, likely one of the first production run. Send it in and I will replace it, the new ones are great pumps and all of these issues have been solved.

Tunze USA
305 Victor St
Austin, TX 78753

Now thats what I call great customer service.
 
Top