Internet Connectivity issue: apex, apple, and mediacom

PotRoast

New member
I know, I know, you have heard it a thousand times over here.....'I can't connect to my apex from outside my home network'.....well.....that is my issue. So any help you can provide will be helpful.

First things first.....I had a person experienced in networking to help me setup my apex. He got it up and running on my home network in a matter of minutes. It has worked flawlessly. However, he had a hell of a time trying to get it recognized outside of my home network. After a few hours of working he finally gave up and essentially blamed all his troubles on his inability to access the settings of my mediacom cable modem.

Since I am a bonehead when it comes to networking, I have not pursued the issue any further. I have read every thread in this forum and I have specifically paid close attention to all the apple related posts, since I am a 'mac guy'. So that is where I am at.

The specifics
1. Apex Heavy
2. iMac
3. Airport base station (at least 6+ years old)
4. Linksys Splitter...(it attaches to my base station and provides 4 ethernet outlets...my apex is hard wired to this device)
5. Mediacom Cable Modem RCA DCM45

Questions:
1. Has anyone had any success connecting from outside your home network with this combination of devices?
2. Has anyone had any success accessing the settings of this Mediacom modem?
3. Is there anyone out there that can help me? I would be willing to kick a $25 gift certificate to the fish store of your choice if you can get me connected.....
 

gravattj

New member
1. Yes with Mediacom and a linksys router. Is your mediacom modem plugged into the linksys via an uplink or wan switch?
2. I have no idea why he wanted access to the modem itself. The configuration is all in the linksys (assuming you have a router and not a switch).
3. No gift certificate necessary. Although a frag or two would be nice :D I think I recognize your name from GIRS and bought a frag or two from you at fall fest.
 

RussM

New member
Is the cable modem model actually the DCM425? Regardless, any model in the DCM series should have nothing to do with the issue at hand... cable modems like that are just media converters - they do not block or otherwise manipulate network traffic.

I'm assuming that the Linksys is a hub or switch, not a router. But let's confirm that - what is the Linksys model number?
 

PotRoast

New member
I gave bluefool a ton of frags for his help so yeah a few frags would be no problem.....I don't have any right now actually but I will soon enough.

To be clear I don't have a Linksys router. My mediacom modem is plugged into the airport base station. The base station sends out my wireless signal. The Linksys splitter is plugged in via ethernet cable to the base station. The splitter has four ethernet out ports...one of them serves the apex. I had to buy the splitter because the base station doesn't have enough ports for my needs.
 

PotRoast

New member
Russ,

Yes it is the DCM 425....if you are laughing, so was my network guy that helped me set it up..... I can confirm that it is indeed this model number after work. But I am as sure as I can be.

The linksys device is not a router. See my response to gravvattj. I can confirm this model number after work as well.
 

Urchinhead

New member
1. Yes
2. No.
3. I will try.

Odds are its one of a couple of issues. And I am going to be as nontechnical as I can be here. My apologies if it gets to technical but I need to get the information across and hopefully someone close to you can help.

Your internet provider doesn't allow you access inbound from the internet to TCP port 80 (what web servers use to "listen" for connections) because they don't want you running a web server from your house without paying for business class service. Cable providers are notorious for this.

The Apex, if I remember right, "listens" on port 80 by default so you could try changing the port in the network settings to something like 8080 or 81 or 8181 etc.

Your cable modem is configured to block inbound access requests via its "firewall" which means you need to get access to it to allow connections inbound. Alternately your Linksys is doing the same.

The cable company is doing Dynamic NAT (Network Address Translation) or (more likely) PAT (Port Address Translation) for the devices on your home network. If its Dynamic NAT then your "real" IP address (an address that works on the Internet) will change periodically.

If its PAT then they are assigning you only one "real" (Internet accessible) IP address so that multiple devices can "share" the same "real" IP address.

To fix the NAT problem you can go about it two ways. Use something like DynamicDNS or the like to find out your assigned IP address and configure your cable modem to allow inbound connections on a designated port to go back to the IP address of your Apex or you can request a "static" IP address from your Cable company and then configure your cable modem to "map" that IP address to certain ports for inbound access.

If its PAT then the same deal applies it just gets a bit more tricky.

Good luck!
 

gravattj

New member
1. Yes
2. No.
3. I will try.

Odds are its one of a couple of issues. And I am going to be as nontechnical as I can be here. My apologies if it gets to technical but I need to get the information across and hopefully someone close to you can help.

Your internet provider doesn't allow you access inbound from the internet to TCP port 80 (what web servers use to "listen" for connections) because they don't want you running a web server from your house without paying for business class service. Cable providers are notorious for this.

In my experience with Mediacom they do not block any inbound traffic. I have successfully sent inbound traffic on port 80, 22, and 8080.

The Apex, if I remember right, "listens" on port 80 by default so you could try changing the port in the network settings to something like 8080 or 81 or 8181 etc.

Your cable modem is configured to block inbound access requests via its "firewall" which means you need to get access to it to allow connections inbound. Alternately your Linksys is doing the same.

Mediacom's cable modems do not block anything in my experience.

The cable company is doing Dynamic NAT (Network Address Translation) or (more likely) PAT (Port Address Translation) for the devices on your home network. If its Dynamic NAT then your "real" IP address (an address that works on the Internet) will change periodically.

If its PAT then they are assigning you only one "real" (Internet accessible) IP address so that multiple devices can "share" the same "real" IP address.

Mediacom does not use PAT to my knowledge.

To fix the NAT problem you can go about it two ways. Use something like DynamicDNS or the like to find out your assigned IP address and configure your cable modem to allow inbound connections on a designated port to go back to the IP address of your Apex or you can request a "static" IP address from your Cable company and then configure your cable modem to "map" that IP address to certain ports for inbound access.

You are confusing NAT with DHCP. NAT is a way to use one internet facing IP and several private IPs which DynDNS will not help with. Mediacom DOES use DHCP so that is where DynDNS would come in. However, they tend to use a one year lease schedule.

If its PAT then the same deal applies it just gets a bit more tricky.

Good luck!
 

gravattj

New member
I gave bluefool a ton of frags for his help so yeah a few frags would be no problem.....I don't have any right now actually but I will soon enough.

To be clear I don't have a Linksys router. My mediacom modem is plugged into the airport base station. The base station sends out my wireless signal. The Linksys splitter is plugged in via ethernet cable to the base station. The splitter has four ethernet out ports...one of them serves the apex. I had to buy the splitter because the base station doesn't have enough ports for my needs.

I don't have experience with the airport base station. Do you have a model number or a version? I suspect it is configurable enough to allow you to forward the necessary port. Even old linksys routers provide this feature.

What is the model on the linksys?
 

Urchinhead

New member

Sorry for this but for some reason I can't quote your post.

1. I have no experience with Mediacom so I can't comment. My experience with Charter is that they do. You know more than I do about them so I have nothing to add here.

2. I am not confusing NAT with DHCP. I implied DHCP when I said that he was assigned a "real" IP address. However my guess would be that the router is doing dynamic NAT or PAT based on the DHCP assigned IP address from the head end CMTS or RADIUS box. Please remember I said I was going to try and keep it as simple as possible and not get to technical.

For the record I don't work with CMTS devices so I can't say nor frankly do I care how they handle assignment of configuration information.

Back to the topic at hand...

Since Mediacom does not block and does not use PAT I believe its going to be either a "firewall" or NAT issue and will require some form of modification/configuration to the cable CPE to make it work.

To confirm you can look at the system preferences/network/built in ethernet/TCP/IP tab to see what your internal Apple IP address is then do a comparison to what something like www.whatismyip.com says. If you see two different addresses then your router is NATing.

This is assuming that the router is handing out DHCP leases on the internal network that is in your home and the APEX is configured to use DHCP. What that means is that instead of manually giving your home computer and the APEX its IP address (Think of it like a telephone number) the router is giving you one to use instead.

Unfortunately you can't check the APEX's NAT address the way you can on the Apple. An educated guess would be that the address assigned to the APEX (assuming that Mediacom doesn't use PAT) would be one up from or one down from the address assigned to your Apple that you see on the www.whatismyip.com site.

You can test this by trying to access the APEX using that guessed number from the outside. If it comes up then you are gold. If not then its more testing and would probably warrant a call to Mediacom tech support.

A bit of advice on calling tech support. The moment you get through to the call center ask very nicely and politely to be connected to Level 2 support. They will initially resist but be firm and if they continue to refuse ask for a manager/supervisor then repeat the request. Tell the Level 2 people what you are trying to do and see what they say.
 

Urchinhead

New member
I don't have experience with the airport base station. Do you have a model number or a version? I suspect it is configurable enough to allow you to forward the necessary port. Even old linksys routers provide this feature.

What is the model on the linksys?

Ah! I missed this. I don't think the airport will do port forwarding nor does it have a NAT feature that I am aware of. Looking at my own Airport I don't see that feature. I think its going to come down to modification of your cable modem's config.
 

gravattj

New member
Ah! I missed this. I don't think the airport will do port forwarding nor does it have a NAT feature that I am aware of. Looking at my own Airport I don't see that feature. I think its going to come down to modification of your cable modem's config.

Does the airport allow you to run multiple devices connected to the internet via one ip? If so it has to have NAT. Whether you can tweak it or not is another story.

If you can't do port forwarding, then my recommendation is to pickup a linksys router at walmart.
 

RussM

New member
Apple routers do not have "port forwarding" - Apple, being Apple, calls it something different: "port mapping". Same thing, different terminology. I have not yet seen an Airport that doesn't have this feature.
 

PotRoast

New member
I'm sorry I am so late responding.

I checked my hardware to confirm model numbers and what not....

1. RCA DCM425 modem
2. Linksys SWITCH. Marked 10/100 on the front and it has five ports on the back.
3. Apple Extreme Base Station. This is my router. It WILL forward ports....as Russ said it is called Port Mapping.

As for DHCP or NAT...I did not dig around in the base station settings but from past experience I am sure you can check boxes for DHCP and NAT settings.

Also, I use a bittorrent program (Transmission) which I use to 'trade' music. The program automatically forwards my ports and/or gets me around any firewalls. My point in saying this is that I believe my computer/router is capable of port forwarding/port mapping.


Q: I had a dyndns address but I believe I let it expire. Should I get a new one?

Where do I go from here?
 

gravattj

New member
1. you will need to assign a static ip to your apex. i suspect you are on a 192.168.1.X network. If that is the case see if you can determine/set the DHCP range. You will want to pick a number outside of that (if possible). A safe number is probably 192.168.1.250.

2. setup port mapping on your airport by forwarding incoming traffic on port 80 to 192.168.1.250 port 80.

3. dyndns is not required, but is helpful. for the purposes of testing you can use www.whatismyip.com (as urchinhead mentioned) and hit the ip directly. your dhcp address from mediacom (internet facing) is not likely to change often.
 

drw94

New member
Not to sure if this helps. I also have apple. Your base station should have an address of 10.0.1.?. Some thing like that. On the apex network setting you should set your gateway, primary and secondary DNS server to your base station address. DHCP should be disabled. Your apex should have and address of 10.0.1.?. I left the ports on 80. With these setting you should be able to access via your computers IP address, which can be found at whatismyip.com. My net mask is set at 255.255.255.0.

Hope this helps.
 

Mantis

Active member
drw94, thank you, thank you, thank you.

I have literally played with this for hours, no connection outside the house, saw your post, bang, it worked. All apple equipment.
 

PotRoast

New member
I tried to tackle this (again) after finding hope from Mantis and Drw94. I am a little shaky on this still. I tried to set it up like drw94 suggested. I checked to see if I could access it on my iphone over 3g with wifi off, and no dice.

I am going to try to insert my apex and modem settings and maybe someone can see what I am doing wrong?

originalapex.jpg


airportsettings.jpg
 

RussM

New member
The first thing I see is that the DNS server settings in the Apex are invalid for your network. Change those from 192.168.1.1 to 10.0.1.1. This only affects the ability to send email though.

That second screen shot is of your Mac's wireless interface IP settings, not the AirPort base station. Use the AirPort Utility found in Applications->Utilities. Click on Manual Setup near the bottom. Then click on Internet near the top. Grab screenshots of all four tabs... Internet Connection, TCP/IP, DHCP, and NAT. Then while still on the NAT tab, click on Configure Port Mappings. Click on the Port Mapping tab. If anything is configured in the Allow list, grab a screen shot.

Post all 4 (or 5) screen shots, or email them to me. I'll PM an email address.
 

RussM

New member
  1. On the Internet->NAT tab, check Enable NAT Port Port Mapping Protocol.
  2. Click Configure Port Mappings.
  3. Click the +
  4. Do *not* choose a service.
  5. Leave Public UDP Port(s) and Private UDP Port(s) blank.
  6. Pick a 4-digit number (>1024) that you will easily remember, and enter it in the Public TCP Port(s) field.
  7. Enter 80 in the Private TCP Port(s) field.
  8. Enter your Apex's IP address (10.0.1.50) in the Private IP Address field.
  9. Click Continue.
  10. Enter a description, such as Apex Web
  11. Leave the Bonjour option unchecked, then click Done.
  12. Click Update.

After the AirPort base station restarts, turn off WiFi on the iPhone, then enter this URL in Safari on the iPhone:

http://173.31.89.213:1234 (use the 4-digit number you picked above in place of 1234)

You should get a login prompt from the Apex.
 
Top