Tank gettin better but still some issues

BadKharma1

In Memoriam
55 gallon tank i started a while ago, went thru the normal "blooms" but still getting what i have been led to belive is cyano and a dark dark green hairy algae. As well as what i thinkn is green bubble algae in a couple spots. Current residents are 4 turbos, 1 Indo Alge Blenny and 6 Chromis. All the residents are live and well, just wonderiing what to do about the algae. Its just plain unsightly. There is only 25 pounds of LR at the moment, this Friday there will be 25 more as weve been snowed in the last week or so.
 

tedmc2

New member
I’d suggest adding more snails. I prefer a variety, something like astraea, nerite and trochus along with the turbos. Depending on the types of snails, you could add another dozen or two. I also like scarlet hermit crabs but hermits have a bed reputation for killing snails.
 

brettaustin

New member
SAME PROBLEM HERE IN MY 54 BOW FRONT. 1 YR OLD AND THE ALGAE BUBBLES FROM THE ROCK AND SAND LIKE A SPECTACLE!:D
I'M SCRUBBING MY ROCK EVERY WEEK!:mad: ASM G5 JUST HOOKED UP. I'M PRAYING FOR SKIM...
 

BadKharma1

In Memoriam
Was using Tap now im using RO. Last change was RO so it may take a bit i spose. Definately getting more snails tho. After getting the rest of the LR in there and lettign it cycle. My plan was to add a Yellow or Blue eyed Bristleback. Any suggestions?
 

jecarl2

New member
It took me 3 water changes over the course of 6 weeks to combat mine. It takes a while to cycle that tap H20 out of there.
 

brettaustin

New member
I HAVE BEEN USING R/O FROM MY OWN SYSTEM BUT NOW I'M WONDERING IF IT'S TIME TO CHANGE THE FILTERS. IT'S BEEN A WHILE PROBABLY OVER A YEAR!:D i'M TAKING MY 2 BAGS OF CHEMI-PURE OUT TOO THINKING IT'S ALSO NOT HELPING (BEEN 2 MONTHS ALREADY). I'VE CLEANED BOTH CANISTER FILTERS AT THE SAME TIME AND THAT DID'NT DO ANYTHING. I ORDERED 50 SNAILS ONLINE THEY AREN'T DOING JUSTICE TO IT. I'M BUILDING MY 150 GAL. INTO THE WALL THIS WEEKEND AND I WANTED TO SOLVE THE PROBLEM BEFORE THEN SINCE I'M CONNECTING THEM TOGETHER AFTER THE NEW ROCK CYCLES! I'M STILL GOING TO FOLLOW THIS THREAD TO SEE IF ANY ONE ELSE WITH MORE EXPIRENCE OR IDEAS RESPONDS...
 

brettaustin

New member
i've cured my algae prob. by using "algae fix" from petco. it's not for saltwater but it totally worked in my tank. Nothing showed any negative signs except my mandarin goby is missing. only positive changes in my corals were noticed (plate,xenia,clams,button polyps,favia and open brain,mushrooms,acroporas,etc. I used 2 doses and all that remains is the dead algae that my turbos love to mow down. Be advised I only tried this as a desperate measure to see if anything good could happen and I have no expert knowledge in reef chemistry. (just to add i only have 2 clowns and a wrasse and most likely a dead goby :( )
 
Top